mirror of
https://github.com/zerotier/ZeroTierOne.git
synced 2025-04-19 21:46:54 +02:00
* add note about forceTcpRelay
* Create a sample systemd unit for tcp proxy
* set gitattributes for rust & cargo so hashes dont conflict on Windows
* Revert "set gitattributes for rust & cargo so hashes dont conflict on Windows"
This reverts commit 032dc5c108
.
* Turn off autocrlf for rust source
Doesn't appear to play nice well when it comes to git and vendored cargo package hashes
* Fix #1883 (#1886)
Still unknown as to why, but the call to `nc->GetProperties()` can fail
when setting a friendly name on the Windows virtual ethernet adapter.
Ensure that `ncp` is not null before continuing and accessing the device
GUID.
* Don't vendor packages for zeroidc (#1885)
* Added docker environment way to join networks (#1871)
* add StringUtils
* fix headers
use recommended headers and remove unused headers
* move extern "C"
only JNI functions need to be exported
* cleanup
* fix ANDROID-50: RESULT_ERROR_BAD_PARAMETER typo
* fix typo in log message
* fix typos in JNI method signatures
* fix typo
* fix ANDROID-51: fieldName is uninitialized
* fix ANDROID-35: memory leak
* fix missing DeleteLocalRef in loops
* update to use unique error codes
* add GETENV macro
* add LOG_TAG defines
* ANDROID-48: add ZT_jnicache.cpp
* ANDROID-48: use ZT_jnicache.cpp and remove ZT_jnilookup.cpp and ZT_jniarray.cpp
* add Event.fromInt
* add PeerRole.fromInt
* add ResultCode.fromInt
* fix ANDROID-36: issues with ResultCode
* add VirtualNetworkConfigOperation.fromInt
* fix ANDROID-40: VirtualNetworkConfigOperation out-of-sync with ZT_VirtualNetworkConfigOperation enum
* add VirtualNetworkStatus.fromInt
* fix ANDROID-37: VirtualNetworkStatus out-of-sync with ZT_VirtualNetworkStatus enum
* add VirtualNetworkType.fromInt
* make NodeStatus a plain data class
* fix ANDROID-52: synchronization bug with nodeMap
* Node init work: separate Node construction and init
* add Node.toString
* make PeerPhysicalPath a plain data class
* remove unused PeerPhysicalPath.fixed
* add array functions
* make Peer a plain data class
* make Version a plain data class
* fix ANDROID-42: copy/paste error
* fix ANDROID-49: VirtualNetworkConfig.equals is wrong
* reimplement VirtualNetworkConfig.equals
* reimplement VirtualNetworkConfig.compareTo
* add VirtualNetworkConfig.hashCode
* make VirtualNetworkConfig a plain data class
* remove unused VirtualNetworkConfig.enabled
* reimplement VirtualNetworkDNS.equals
* add VirtualNetworkDNS.hashCode
* make VirtualNetworkDNS a plain data class
* reimplement VirtualNetworkRoute.equals
* reimplement VirtualNetworkRoute.compareTo
* reimplement VirtualNetworkRoute.toString
* add VirtualNetworkRoute.hashCode
* make VirtualNetworkRoute a plain data class
* add isSocketAddressEmpty
* add addressPort
* add fromSocketAddressObject
* invert logic in a couple of places and return early
* newInetAddress and newInetSocketAddress work
allow newInetSocketAddress to return NULL if given empty address
* fix ANDROID-38: stack corruption in onSendPacketRequested
* use GETENV macro
* JniRef work
JniRef does not use callbacks struct, so remove
fix NewGlobalRef / DeleteGlobalRef mismatch
* use PRId64 macros
* switch statement work
* comments and logging
* Modifier 'public' is redundant for interface members
* NodeException can be made a checked Exception
* 'NodeException' does not define a 'serialVersionUID' field
* 'finalize()' should not be overridden
this is fine to do because ZeroTierOneService calls close() when it is done
* error handling, error reporting, asserts, logging
* simplify loadLibrary
* rename Node.networks -> Node.networkConfigs
* Windows file permissions fix (#1887)
* Allow macOS interfaces to use multiple IP addresses (#1879)
Co-authored-by: Sean OMeara <someara@users.noreply.github.com>
Co-authored-by: Grant Limberg <glimberg@users.noreply.github.com>
* Fix condition where full HELLOs might not be sent when necessary (#1877)
Co-authored-by: Grant Limberg <glimberg@users.noreply.github.com>
* 1.10.4 version bumps
* Add security policy to repo (#1889)
* [+] add e2k64 arch (#1890)
* temp fix for ANDROID-56: crash inside newNetworkConfig from too many args
* 1.10.4 release notes
---------
Co-authored-by: travis laduke <travisladuke@gmail.com>
Co-authored-by: Grant Limberg <grant.limberg@zerotier.com>
Co-authored-by: Grant Limberg <glimberg@users.noreply.github.com>
Co-authored-by: Leonardo Amaral <leleobhz@users.noreply.github.com>
Co-authored-by: Brenton Bostick <bostick@gmail.com>
Co-authored-by: Sean OMeara <someara@users.noreply.github.com>
Co-authored-by: Joseph Henry <joseph-henry@users.noreply.github.com>
Co-authored-by: Roman Peshkichev <roman.peshkichev@gmail.com>
270 lines
8.6 KiB
Text
270 lines
8.6 KiB
Text
zerotier-one (1.10.4) unstable; urgency=medium
|
|
|
|
* See RELEASE-NOTES.md for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Mon, 06 Mar 2023 01:00:00 -0700
|
|
|
|
zerotier-one (1.10.3) unstable; urgency=medium
|
|
|
|
* See RELEASE-NOTES.md for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Sat, 21 Jan 2023 01:00:00 -0700
|
|
|
|
zerotier-one (1.10.2) unstable; urgency=medium
|
|
|
|
* See RELEASE-NOTES.md for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Thu, 13 Oct 2022 01:00:00 -0700
|
|
|
|
zerotier-one (1.10.1) unstable; urgency=medium
|
|
|
|
* See RELEASE-NOTES.md for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Mon, 27 Jun 2022 01:00:00 -0700
|
|
|
|
zerotier-one (1.10.0) unstable; urgency=medium
|
|
|
|
* See RELEASE-NOTES.md for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Fri, 03 Jun 2022 01:00:00 -0700
|
|
|
|
zerotier-one (1.8.10) unstable; urgency=medium
|
|
|
|
* See RELEASE-NOTES.md for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Tue, 10 May 2022 01:00:00 -0700
|
|
|
|
zerotier-one (1.8.9) unstable; urgency=medium
|
|
|
|
* See RELEASE-NOTES.md for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Mon, 25 Apr 2022 01:00:00 -0700
|
|
|
|
zerotier-one (1.8.8) unstable; urgency=medium
|
|
|
|
* See RELEASE-NOTES.md for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Mon, 11 Apr 2022 01:00:00 -0700
|
|
|
|
zerotier-one (1.8.7) unstable; urgency=medium
|
|
|
|
* See RELEASE-NOTES.md for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Mon, 21 Mar 2022 01:00:00 -0700
|
|
|
|
zerotier-one (1.8.6) unstable; urgency=medium
|
|
|
|
* See RELEASE-NOTES.md for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Mon, 07 Mar 2022 01:00:00 -0700
|
|
|
|
zerotier-one (1.8.5) unstable; urgency=medium
|
|
|
|
* See RELEASE-NOTES.md for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Fri, 17 Dec 2021 01:00:00 -0700
|
|
|
|
zerotier-one (1.8.4) unstable; urgency=medium
|
|
|
|
* See RELEASE-NOTES.md for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Mon, 23 Nov 2021 01:00:00 -0700
|
|
|
|
zerotier-one (1.8.3) unstable; urgency=medium
|
|
|
|
* See RELEASE-NOTES.md for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Mon, 15 Nov 2021 01:00:00 -0700
|
|
|
|
zerotier-one (1.8.2) unstable; urgency=medium
|
|
|
|
* See RELEASE-NOTES.md for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Mon, 08 Nov 2021 01:00:00 -0700
|
|
|
|
zerotier-one (1.8.1) unstable; urgency=medium
|
|
|
|
* See RELEASE-NOTES.md for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Wed, 20 Oct 2021 01:00:00 -0700
|
|
|
|
zerotier-one (1.8.0) unstable; urgency=medium
|
|
|
|
* See RELEASE-NOTES.md for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Wed, 15 Sep 2021 01:00:00 -0700
|
|
|
|
zerotier-one (1.6.6) unstable; urgency=medium
|
|
|
|
* Backport endpoint mitigation against address collision attack.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Tue, 21 Sep 2021 01:00:00 -0700
|
|
|
|
zerotier-one (1.6.5) unstable; urgency=medium
|
|
|
|
* Fix path filtering bug that could cause "software laser" effect.
|
|
* Fix printf overflow in CLI (not exploitable or security related)
|
|
* Fix Windows device enumeration issue.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Tue, 13 Apr 2021 01:00:00 -0700
|
|
|
|
zerotier-one (1.6.4) unstable; urgency=medium
|
|
|
|
* REALLY fix a problem causing nodes to go into a "coma" with some network configurations.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Tue, 15 Feb 2021 01:00:00 -0700
|
|
|
|
zerotier-one (1.6.3-1) unstable; urgency=medium
|
|
|
|
* Fix a problem causing nodes to go into a "coma" with some network configurations.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Tue, 02 Feb 2021 01:00:00 -0700
|
|
|
|
zerotier-one (1.6.2-2) unstable; urgency=medium
|
|
|
|
* This is a minor update to the 1.6.2 package to address issues with
|
|
running on ARMv6 CPUs like the Raspberry Pi Zero and original v1 Pi.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Tue, 31 Nov 2020 01:00:00 -0700
|
|
|
|
zerotier-one (1.6.2) unstable; urgency=medium
|
|
|
|
* See RELEASE-NOTES.md for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Mon, 30 Nov 2020 01:00:00 -0700
|
|
|
|
zerotier-one (1.6.1) unstable; urgency=medium
|
|
|
|
* See RELEASE-NOTES.md for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Tue, 24 Nov 2020 01:00:00 -0700
|
|
|
|
zerotier-one (1.6.0) unstable; urgency=medium
|
|
|
|
* See RELEASE-NOTES.md for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Thu, 19 Nov 2020 01:00:00 -0700
|
|
|
|
zerotier-one (1.5.0) unstable; urgency=medium
|
|
|
|
* Version 1.5.0 is actually 1.6.0-beta1
|
|
* See RELEASE-NOTES.md for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Mon, 05 Aug 2020 01:00:00 -0700
|
|
|
|
zerotier-one (1.4.6) unstable; urgency=medium
|
|
|
|
* Update default root server list
|
|
* Fix build flags on "armhf" (32-bit ARM) platforms for better
|
|
compatibility with Pi Zero and other devices.
|
|
* Fix license text in one.cpp.
|
|
* Add a clarification to LICENSE.txt.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Fri, 30 Aug 2019 01:00:00 -0700
|
|
|
|
zerotier-one (1.4.4) unstable; urgency=medium
|
|
|
|
* See https://github.com/zerotier/ZeroTierOne for release notes.
|
|
* License changed to BSL 1.1
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Fri, 23 Aug 2019 01:00:00 -0700
|
|
|
|
zerotier-one (1.4.2-2) unstable; urgency=medium
|
|
|
|
* See https://github.com/zerotier/ZeroTierOne for release notes.
|
|
* This is a new build that fixes a binary build issue with containers and SELinux
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Thu, 04 Aug 2019 01:00:00 -0700
|
|
|
|
zerotier-one (1.4.2) unstable; urgency=medium
|
|
|
|
* See https://github.com/zerotier/ZeroTierOne for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Thu, 04 Aug 2019 01:00:00 -0700
|
|
|
|
zerotier-one (1.4.0) unstable; urgency=medium
|
|
|
|
* See https://github.com/zerotier/ZeroTierOne for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Thu, 29 Jul 2019 01:00:00 -0700
|
|
|
|
zerotier-one (1.2.12) unstable; urgency=medium
|
|
|
|
* See https://github.com/zerotier/ZeroTierOne for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Tue, 25 Jul 2018 01:00:00 -0700
|
|
|
|
zerotier-one (1.2.10) unstable; urgency=medium
|
|
|
|
* See https://github.com/zerotier/ZeroTierOne for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Tue, 08 May 2018 01:00:00 -0700
|
|
|
|
zerotier-one (1.2.8) unstable; urgency=medium
|
|
|
|
* See https://github.com/zerotier/ZeroTierOne for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Tue, 27 Apr 2018 01:00:00 -0700
|
|
|
|
zerotier-one (1.2.6) unstable; urgency=medium
|
|
|
|
* See https://github.com/zerotier/ZeroTierOne for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Tue, 17 Apr 2018 01:00:00 -0700
|
|
|
|
zerotier-one (1.2.4) unstable; urgency=medium
|
|
|
|
* See https://github.com/zerotier/ZeroTierOne for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Mon, 24 Mar 2017 01:00:00 -0700
|
|
|
|
zerotier-one (1.2.2) unstable; urgency=medium
|
|
|
|
* See https://github.com/zerotier/ZeroTierOne for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Fri, 17 Mar 2017 01:00:00 -0700
|
|
|
|
zerotier-one (1.2.0) unstable; urgency=medium
|
|
|
|
* See https://github.com/zerotier/ZeroTierOne for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Tue, 14 Mar 2017 09:08:00 -0700
|
|
|
|
zerotier-one (1.1.14) unstable; urgency=medium
|
|
|
|
* See https://github.com/zerotier/ZeroTierOne for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Tue, 21 Jul 2016 07:14:12 -0700
|
|
|
|
zerotier-one (1.1.12) unstable; urgency=medium
|
|
|
|
* See https://github.com/zerotier/ZeroTierOne for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Tue, 12 Jul 2016 03:02:22 -0700
|
|
|
|
zerotier-one (1.1.10) unstable; urgency=medium
|
|
|
|
* See https://github.com/zerotier/ZeroTierOne for release notes.
|
|
* ZeroTier Debian packages no longer depend on http-parser since its ABI is too unstable.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Tue, 12 Jul 2016 12:29:00 -0700
|
|
|
|
zerotier-one (1.1.8) unstable; urgency=low
|
|
|
|
* See https://github.com/zerotier/ZeroTierOne for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Fri, 08 Jul 2016 01:56:00 -0700
|
|
|
|
zerotier-one (1.1.6) unstable; urgency=medium
|
|
|
|
* First Debian release on ZeroTier, Inc. private apt repository.
|
|
|
|
* See https://github.com/zerotier/ZeroTierOne for release notes.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Fri, 24 Jun 2016 10:00:00 -0700
|
|
|
|
zerotier-one (1.1.5) UNRELEASED; urgency=medium
|
|
|
|
* Development package -- first clean Debian packaging test.
|
|
|
|
-- Adam Ierymenko <adam.ierymenko@zerotier.com> Wed, 08 Jun 2016 10:05:01 -0700
|