New Package: voidnsundo-2022.07.30_1
This commit is contained in:
parent
47bf6ff60a
commit
c22a7b218c
2 changed files with 42 additions and 0 deletions
19
srcpkgs/voidnsundo/patches/musl-stat.patch
Normal file
19
srcpkgs/voidnsundo/patches/musl-stat.patch
Normal file
|
@ -0,0 +1,19 @@
|
|||
diff --git a/voidnsundo.c b/voidnsundo.c
|
||||
index 9639d51..0731cd3 100644
|
||||
--- a/voidnsundo.c
|
||||
+++ b/voidnsundo.c
|
||||
@@ -12,6 +12,7 @@
|
||||
#include <sys/socket.h>
|
||||
#include <sys/un.h>
|
||||
#include <linux/limits.h>
|
||||
+#include <sys/stat.h>
|
||||
|
||||
#include "config.h"
|
||||
#include "utils.h"
|
||||
@@ -124,4 +125,4 @@ end:
|
||||
close(sock_fd);
|
||||
|
||||
return exit_code;
|
||||
-}
|
||||
\ No newline at end of file
|
||||
+}
|
23
srcpkgs/voidnsundo/template
Normal file
23
srcpkgs/voidnsundo/template
Normal file
|
@ -0,0 +1,23 @@
|
|||
# Template file for 'voidnsundo'
|
||||
pkgname=voidnsundo
|
||||
version=2022.07.30
|
||||
revision=1
|
||||
wrksrc=voidnsrun-master
|
||||
repository="cereus-extra"
|
||||
hostmakedepends="make gcc"
|
||||
short_desc="Run binaries in the parent mount namespace from within the mount namespace created by voidnsrun"
|
||||
maintainer="Kevin F. <https://github.com/KF-Art>"
|
||||
license="BSD-2-Clause"
|
||||
homepage="https://github.com/gch1p/voidnsrun"
|
||||
distfiles="${homepage}/archive/refs/heads/master.zip"
|
||||
checksum=693ec1c3e225fb5605c5aeb5d06d769d857b95482558fc490f189921d9341850
|
||||
|
||||
do_build() {
|
||||
make undo
|
||||
}
|
||||
|
||||
do_install() {
|
||||
vmkdir usr/bin
|
||||
vinstall voidnsundo 4755 usr/bin/
|
||||
vlicense LICENSE
|
||||
}
|
Loading…
Add table
Reference in a new issue